Jump to content


Welcome to S12Silvia.com Community

Hey there! We've noticed you are a Guest. Why not register with S12Silvia.com to take full advantage of our many features.

Like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the XII revolution by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Upload images to posts or our community gallery
  • Customize your experience here
Click here to sign up now!
Guest Message by DevFuse
 

Photo
- - - - -

no power to anywhere in car


  • Please log in to reply
1 reply to this topic

#1 Marshall.n

Marshall.n

    New Member

  • Members
  • 1 posts
  • Name:Marshall
  • Car:1985 s12

Posted 12 April 2014 - 01:42 AM

hey guys i drive an 85 200sx s12 and the other day i went to start it up but there was no power going anywhere, no dash lights, no interior lights or anything. obviously the first thing i checked was my battery, i charged it up fully and tested it. the battery has a full charge and it holds a load but there is no power going from the battery to anywhere in the car and all the fuses are good. I've just been trying to follow wires from the battery and testing things. the car was running the day before then all of a sudden no power anywhere. if anyone has any info on what the issue could be or how to fix it please let me know, thanks.

 



#2 dustin_rps12

dustin_rps12

    I

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:JAX, Florida, USA
  • Name:Dustin McSwain
  • Car:1986 Nissan RPS12
Garage View Garage

Posted 12 April 2014 - 08:05 AM

Could be an alternator or grounding issue. Usually current can't travel if its not grounded.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users